Update Documentation Theme for Jekyll

Contonuo a lavorare su questo tema:

https://idratherbewriting.com/documentation-theme-jekyll/index.html

Sono andata a spulciare le dipendenze dalle librerie e loro versioni.

Come lista le vedo qui: _includes/head.html

Ci sono.. alcuni CDN, quindi chiamate in remoto ma non all’ultima versione:

  • bootstrapt alla 3.3.7 >>> ora alla 4.3  ma la 3.3.7 è ancora supportata
  • jquery 2.1.4  >>> ora 3.3.1 le precedenti (1.* e 2.* ) non ricevono update di sicurezza.
  • jquery cookye 1.4.1  >>> BHO.. quella è l’ultima versione esistente, è del 2014, o non ha bug .. https://plugins.jquery.com/cookie/
  • anchor-js/2.0.0  >>>   è alla 4.2   viene mantenuto https://github.com/bryanbraun/anchorjs/releases
  • font awesome alla 4.7.0 >>> ora alla 5.7.2  non mantengono più la 4

Altre librerie meno note stanno dentro alla cartella  js/:

Ora io vorrei aggiornare il tutto e lo farò secondo due criteri.

Provare ad usare i pacchetti gemme ed eliminare i CDN così ci si può lavorare in locale.

Qualche ispirazione, dove un altro essere umano si domanda.. su quattro vie diverse di far ela stess cosa.. cosa gli conviene.

Ha scelto una via simile :) https://phalski.com/using-bootstrap-jekyll-gem-theme.html

Potrei provare ad installare tutto come gemme..

gem "jquery-rails", "~> 3.0"
gem 'font-awesome-less', '~> 4.7.0'
gem "bootstrap", "~> 4.3.1"

Però prima le cose urgenti, quindi provare l’update di anchor.js e di jquery all 3. Usando comunque i CDN

Sembra andare!